Issues despatching with DHL\UK Mail
Incident Report for StoreFeeder
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 13:32 GMT
Monitoring
We have had a few reports of intermittent issues despatching with DHL. This does appear to be a problem on their side as waiting a while and retrying usually allows the despatch to happen.

We are monitoring but currently, it is out of our hands. We advise you give it 15-20 minutes and retry the despatch.

We will update this page if any more information becomes available.

Thanks,

Ths StorFeeder Team
Posted Nov 12, 2021 - 13:53 GMT
This incident affected: Parcel Carriers (excl. Royal Mail) (UK Mail / DHL Parcel UK).