Reports of problems with Amazon Buy Shipping
Incident Report for StoreFeeder
Resolved
As far as we can tell, this incident appears to be resolved on Amazon's end, as we have had no further reports.
Posted Sep 17, 2021 - 15:02 BST
Monitoring
We are monitoring the situation as it appears to be intermittently failing with successful requests in between.
Posted Sep 17, 2021 - 11:13 BST
Investigating
We have been made aware that some users are unable to generate labels via Amazon's Buy Shipping platform. We are currently investigating but we have also seen issues with other providers so at first look this appears to be an Amazon issue.

Amazon's status pages are still showing as healthy and we are trying to contact them for more information.

We will update this page as more information becomes available.
Posted Sep 17, 2021 - 11:01 BST
This incident affected: Parcel Carriers (excl. Royal Mail) (Amazon Logistics / Buy Shipping).