Amazon connection issues

Incident Report for StoreFeeder

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 09:28 GMT

Monitoring

The problem was discovered and isolated.

All integrations should reconnect successfully now.
Posted Mar 26, 2026 - 15:58 GMT

Investigating

We have been made aware that some customers are experiencing issues with their Amazon connections.

We are investigating as a top priority and will update this page with any updates as we find them

There is no need to contact us again if you are affected.
Posted Mar 26, 2026 - 15:41 GMT
This incident affected: Marketplaces (Amazon).