SF SLowness

Incident Report for StoreFeeder

Resolved

This incident has now been resolved
Posted Jul 01, 2025 - 13:13 BST

Investigating

We have had reports of SF being slow. We are currently investigating and will provide further updates as they come along. There is no need to get in contact with Support as we are already looking into this.
Posted Jul 01, 2025 - 12:21 BST
This incident affected: StoreFeeder Main System.