Reports of Slowness

Incident Report for StoreFeeder

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 11:18 BST

Monitoring

We have taken steps to mitigate the slowness. We are continuing to monitor but it is looking good so far. If you experience any timeouts or similar issues, please try clearing your cache and cookies and try again. If you continue to have issues after clearing, please contact us and let us know what you were attempting.

Best Regards,
StoreFeeder Support
Posted Jul 03, 2025 - 10:23 BST

Investigating

Dear customers,

We have received reports of slowness this morning and we have started investigating the cause. We will look to get everything back to normal as soon as possible.

You do not have to contact support about this issue as we are aware and investigating.

Best regards,
StoreFeeder Support
Posted Jul 03, 2025 - 09:11 BST
This incident affected: StoreFeeder Main System.