We have had no further reports of this happening today, so despite no official communication from Amazon, we believe they have resolved their issue that was causing this.
Posted Feb 21, 2025 - 15:30 GMT
Monitoring
We have had reports of two similar issues relating to Amazon orders and labels created through Amazon Buy Shipping
1. Orders are importing with no address. 2. When despatching an order using an Amazon Buy Shipping shipping method, the label has no address.
We are investigating this further, but the initial findings seem to suggest it is an Amazon issue.
It only seems to be affecting random orders, not all, and when we request an Amazon Buy Shipping label from Amazon, we simply send the Amazon order number, the address details are populated by Amazon Buy Shipping.
The fact it is not affecting all orders and that these labels are also being rendered without the address, suggests the address issue is with Amazon itself.
Therefore there is little we can do. We are checking all Amazon connections this end as a matter of course.
We will continue to monitor.
Posted Feb 20, 2025 - 14:03 GMT
This incident affected: Marketplaces (Amazon) and Parcel Carriers (excl. Royal Mail) (Amazon Logistics / Buy Shipping).