Reports of Slowness

Incident Report for StoreFeeder

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 14:35 BST

Monitoring

We have taken actions to resolve the issue and we are continuing to monitor. If you are still having issues, try clearing your cache and cookies from your browser. If you still have issues after clearing, please contact support and tell us what you are attempting
Posted Jul 04, 2025 - 13:58 BST

Investigating

Dear Customers,

We have had reports of Storefeeder being slow and timing out. We are investigating the issue and looking to resolve ASAP.

You do not have to contact Support as we are already taking steps to mitigate and resolve.

Best Regards,
StoreFeeder Support
Posted Jul 04, 2025 - 13:15 BST
This incident affected: StoreFeeder Main System.